欢迎来到站圈网!

媒体php远程七牛摇摇node

投稿中心

Java

当前位置: 主页 > 编程语言 > Java

Maven编译器插件版本指定方法

时间:2022-01-18|栏目:Java|点击:
    内容页广告位

maven-compiler-plugin版本指定

spring cloud微服务,生成部署JAR包时提示:

maven-compiler-plugin: 3.8.1不能编译,需要jre而不是jdk。

maven-compiler-plugin版本指定方式

1 pom文件添加支持

    <!-- 部署版本生成时的插件编译支持>
    <dependency>
      <groupId>org.apache.maven.plugins</groupId>
      <artifactId>maven-compiler-plugin</artifactId>
      <version>3.8.1</version>
    </dependency -->
<!-- 部署版本生成时的插件编译支持 -->

一般情况,做这一步就可以了,若不可以再进行下面步骤。

2 环境jdk/jre指定

maven-compiler-plugin版本指定方式

maven-compiler-plugin版本指定方式

3 Java Build

maven-compiler-plugin版本指定方式

4 pom文件去除支持

通常上面三个步骤说可以,再次构建时若又提示不能编译,可注释掉相应支持,即可。

    <!-- 部署版本生成时的插件编译支持>
    <dependency>
      <groupId>org.apache.maven.plugins</groupId>
      <artifactId>maven-compiler-plugin</artifactId>
      <version>3.8.1</version>
    </dependency -->

maven-compiler-plugin配置JDK版本

Maven3.x 项目中默认使用 JDK1.5,这显然不是我想要的。 Apache Maven Compiler Plugin 可以用来配置编译所用的 JDK版本

仓库地址

https://mvnrepository.com/artifact/org.apache.maven.plugins/maven-compiler-plugin

  • <version>2.3.2</version> 2.4 以上才支持 servlet 3.0
  • 我猜去掉 <version>2.3.2</version> 应该默认用最新版,所以是 Servlet 3.1

使用过的配置

  • JDK1.7
  • Servlet 3.0
    <build>
        <finalName>kerduo</finalName>
        <plugins>  
            <plugin>  
                <groupId>org.apache.maven.plugins</groupId>  
                <artifactId>maven-compiler-plugin</artifactId>  
                <version>2.3.2</version> 
                <configuration>  
                    <source>1.7</source>  
                    <target>1.7</target>  
                </configuration>  
            </plugin>  
        </plugins> 
    </build>
  • JDK1.8
  • Servlet 3.1
  <build>
    <finalName>demo</finalName>
    <plugins>  
            <plugin>  
                <groupId>org.apache.maven.plugins</groupId>  
                <artifactId>maven-compiler-plugin</artifactId>  
                <version>3.7.0</version>  
                <configuration>  
                    <source>1.8</source>  
                    <target>1.8</target>  
                </configuration>  
            </plugin>  
        </plugins> 
  </build>

补充说明

  • maven-compiler-plugin:控制编译 (所以JDK版本是设置这它)
  • spring-boot-maven-plugin 用于打包

以上为个人经验,希望能给大家一个参考,也希望大家多多支持站圈网。

版权声明:本文内容由小编收集网络,均来自网络用户自发贡献,版权归原作者所有,Web前端、电脑编程学习类网站不拥有其著作权,亦不承担相应法律责任。具体规则请查看《Web前端、电脑编程学习类网站用户服务协议》和《Web前端、电脑编程学习类网站知识产权保护指引》。如果您发现本站中有涉嫌抄袭的内容,填写联系本站管理员,一经查实,管理员将立刻删除涉嫌侵权内容。

上一篇:springboot中POM file}项目的错误报告

下一篇:springboot内部和外部logback多环境配置的详细

本文标题:Maven编译器插件版本指定方法

本文地址:https://www.zhano.cn/Java/55148.html

AD300

广告投放 | 联系我们 | 版权申明 | SiteMap

重要申明:本站所有的文章、图片、评论等,均由网友发表或上传并维护或收集自网络,属个人行为,与本站立场无关。

如果侵犯了您的权利,请与我们联系,我们将在24小时内进行处理、任何非本站因素导致的法律后果,本站均不负任何责任。

联系QQ:15234109 | 邮箱:15234109#qq.com(#换成@)

Copyright © 2019-2021 豫ICP备19001789号